mysql驱动包与mysql版本

当然最好是mysql版本对应相应的驱动,但高版本的驱动一般都能兼容低版本的.首先得保证有驱动,数据库连接权限,驱动要放进自己的程序里,一般没什么问题,给你一个程序,也是刚才别人问我的,他的程序没有问题.import java.sql.*;

jdbc和连接池对于你这个场景来说,都足够,既然用spring管理了,建议还是使用连接池,另外,spring自身没有实现连接池,一般都是对第三方连接池的包装,常见的有C3P0,dbcp以及最近比较流行的boneCP等,这几个配置都差不多太多,以boneCP为例:

这跟Mysql的版本和JDK的版本升级是有关系的,Mysql从3.x 4.x 到5.x都不同版本的mysql-connector/J,在Mysql官网可以看到每个版本的mysql-connector/J的ChangeLog,现有的版本号是:5.1.x、5.0.x、3.1.x、3.0.x、2.0.x和1.2.x,每一个版本的

再附上6.0的链接,发现能支持mysql5.5的就5.1和6.0的驱动了

不是,可以对应5.0以上的都可以的

安装包是mysql的核心,简单点说就是存放和管理你的数据的地方.驱动是起着连接java和mysql的桥梁,你想用java存取数据都要通过这个桥梁.sql文件是一些sql语句,用来创建数据库或增删数据用的,应该不用加到java项目去吧.如果你想执行这个sql文件,就打开mysql的命令提示窗口,输入\. 文件的路径

放在Tomcat的common lib下面那种方式就不是jdbc了,是JNDI,数据连接池的意思; 放在程序lib下面,虽是jdbc的连接,但你用数据源的方式,也就是桥连的方式去做,难免出现问题. 本身Mysql-connector-java-5.0.6-bin.jar是java直连MySql数据库的驱动包,现在使用桥连等于另外又建立了一种连接方式,跟jdbc是两码事~ 路过~

这两个文件是压缩文件,只是格式不一样.你问的根本不对,人家怎么回答.这俩解压出来都是jdbc的驱动包.解压后的格式是mysql-connector-java-5.1.46.jar

呵呵.不一定要相同,不过最好jdbc驱动的版本等于或者高于mysql的版本

1.用tomact去配置数据库连接池,具体操作在:http://wenku.baidu.com/view/7006bdc408a1284ac85043d1.html2.去百度文库里查DBhelper类,很多人上传了 稍微改下就行

相关文档

java连接mysql的驱动包
mysql驱动安装
navicat版本太低影响
mysql和驱动的版本对照
怎么修改mysql驱动版本
mysql数据库驱动包
mysql版本jdbc驱动
mysql驱动包安装教程
sytn.net
nnpc.net
2639.net
ceqiong.net
ddgw.net
电脑版